Enigma TIN verification service disruption

Incident Report for Enigma

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 02:35 UTC

Identified

We’re experiencing a service disruption to the KYB service's TIN verification component. If you use our API to verify TINs/EINs, you may encounter an error. Our team is currently working to restore the service, and we apologize for any inconvenience.
Posted Aug 27, 2025 - 00:09 UTC
This incident affected: KYB Tasks (TIN Verification) and KYB API.