IRS TIN Match degraded performance

Incident Report for Enigma

Resolved

IRS servers are responding normally to TIN verification requests.
Posted Sep 12, 2025 - 05:59 UTC

Monitoring

IRS servers are currently not responding to TIN verification requests. This is common during busy periods and is likely to resolve soon. Our team is monitoring the situation.
Posted Sep 12, 2025 - 05:44 UTC
This incident affected: KYB Tasks (TIN Verification).