Enigma KYB watchlist screening disruption

Incident Report for Enigma

Resolved

This incident has been resolved. Service is fully operational.
Posted Oct 20, 2025 - 09:34 UTC

Investigating

We’re experiencing a disruption to the KYB service's watchlist screening component. If you use our API to screen entities against government watchlists, you may encounter an error. Our team is currently working to restore the service, and we apologize for any inconvenience.
Posted Oct 20, 2025 - 07:02 UTC
This incident affected: KYB Tasks (Watchlist Screening) and KYB API.