Enigma KYB degraded performance

Incident Report for Enigma

Resolved

This incident has been resolved. Service is fully operational.
Posted Jul 16, 2025 - 02:15 UTC

Investigating

We’re currently experiencing degraded performance issues with the KYB service. Our team is currently working to restore normal performance levels. We apologize for any inconvenience.
Posted Jul 16, 2025 - 02:15 UTC
This incident affected: KYB API.